This project is read-only.

Problem w/ single data element in FoxCharts

Topics: Attention VFPX Admins, Bug Information
May 26, 2009 at 12:03 PM

I have an instance where depending on the data selected could result in a single point. When trying to plot a single point using FoxChart with either line and/or point (have not tried it with others) it results in you just getting an empty chart. Why can't there be a plot of a single point? An example drawing data for a specific month...if you are plotting by month then it will be one point it will not chart...if you select at least 2 points...then it has no problem.

I have put this into a simplistic program and attached it to the corresponding item in the "Issue Tracker" in order to better illustrate the issue which I am having.

May 28, 2009 at 2:47 PM

Hi Chamlin,

 

This is possible already in Version 1.17

Please run the sample ChartsSample_Builder.scx

Change your chart to "lines", and set the "Depth" to 0 - zero, for plain charts.

And you'll see some isolated shapes, when their value is between NULL values, like in the sample.

Other settings are allowed as well, for defining the shapes size, and even for selecting a unique shape for all line caps.





Just released version 1.17 of FoxCharts.
Many new possibilities have been added, and small tweaks and fixes.

Line charts allow using images for the caps, customized shapes, etc.
Some color pallettes were introduced as well - now the property "ColorType" can accept values from 0 to 27, each of them providing different color options.
0 = Basic colors
1 = Custom colors
2 = Random Colors
3 = Gradient Colors
4 - 27 = Predefined palette colors.

The best way to test this and other features is to download the latest release and polay with the form "ChartsSample_Builder", that provides ways to customize 95% of the properties available, and generate many kinds of charts.

http://vfpx.codeplex.com/Release/ProjectReleases.aspx?ReleaseId=18515

Hope this helps !

Regards

Cesar

May 28, 2009 at 3:03 PM

I used my "test.prg" which is attached to the issue which I posted with 1.17 and got the exact same results...so this is not yet been resolved. The issue is NOT that I am getting an orphaned point...it is that I am getting absolutely NO point. You get an absolutely blank chart. See my test.prg as an example of the issue.

May 30, 2009 at 4:50 AM

Hi Chamlin,

Thanks for all the feedback.

This and the PageFrame issues have been solved.

Please get version 1.17b, and tell me how it goes !

Regards

Cesar