Data environment

Sep 3, 2008 at 3:16 PM
Hi
I strted use with explorer bar, very nice.
The problem is that I lose the data envirnment.
I open the tables in data environment in my topform (wich Explorer bar is on this topform).
Thanks for help
Developer
Sep 3, 2008 at 5:00 PM
Edited Sep 3, 2008 at 5:07 PM
Hi Chaim!
Are you creating ThemesManager manually, before instatiate your form?
If not, place the following code in some place before the call to your form:

If Not Vartype(_Screen.ThemesManager)=="O"
   _Screen.Newobject("ThemesManager","ThemesManager","ThemedControls.vcx")
Endif

Let me know if it solved your problem.

Regards,

Emerson

 

Sep 3, 2008 at 5:26 PM
Thank you
I have the problem in the client office, I dont have it in my computer.
I will add your code to project and will will check it soon (till tomorrow).
I very appreciate your help
again Thanks
Developer
Sep 3, 2008 at 5:59 PM
I've also tried to reproduce the error here without success.
Could you provide more details about the error or send me some code to reproduce it?
Developer
Sep 17, 2008 at 7:28 PM
Hi Chaim!
Any news?
Sep 18, 2008 at 6:27 AM
Hi
Thanks for respond.
Can you show me code that show other EXE inside vfp form - I can move to the other exe and to vfp again and again as any othe two vfp object?
(vfp form - model, intoplevel).
Thanks

Developer
Sep 19, 2008 at 6:31 PM
Chaim,

The code that I've tried doesn't "show other exe inside VFP form".
It just call notepad when you click in a button.
If you want to see the sample, download it here:
http://cid-7caeae63ed3a9a67.skydrive.live.com/self.aspx/P%c3%bablico/Tests.zip
Note that to work correctly, you need to unzip it to a folder named Visual FoxPro in your C: drive or you need to change the hardcoded paths before run the sample.

I would like that you answer the original question that you posted in this thread about to loose DataEnvironment in a form with ExplorerBar control.
You still didn't answered if you found the problem cause or not.
Please, let us know what happened.

Thanks,

Emerson
Sep 20, 2008 at 6:16 PM
Hi

Thank's for respond.
I VERY apperciate your help.
 
I sorry for my poor english,

1. Data Environment
I didnt resolve my problem, but I hope to take care on this this week.
 Meanwhile I wroth a function in main program of my project that run "if not used ('table1') use table1 again in 0if not used ('table2')...for all tables)" and I call this function every child form.

2. EXE inside VFP
I got your code, you didnt resolve my problem (but BTW the code helped me in other things, thank's).
I know that there is solution. I seen few years ago example of manipulating other EXE inside VFP (main?) form, but I dont remember where did I see it. 

Have a good day
Developer
Sep 23, 2008 at 11:29 AM
Chaim,
What type of DataSession are you using? Default or Private?
Let me know if you found the bug cause.
Cheers.