This project is read-only.

FontCharSet behaviour in FoxCharts

Topics: Bug Information, Enhancement Request, General
Nov 7, 2009 at 7:47 PM

Hello,

I am using FoxCharts to create charts in different languages. Among these, there are languages like german, french, romanian, which use special characters (accents, diacritics). The Windows setting "Language for non-Unicode programs" is set to "English (United States)".

I tried to set the FontCharSet property for the Title, SubTitle and Axes in the chart object to 238 (for Central Europe languages) and it doesn't change anything.

Is there a workaround for this? I also posted this in "Issue Tracker"

Thank you.

Lucian

Nov 15, 2009 at 8:22 PM

Hi Lucian,

 

what exactly do you expect FoxCharts to do.? If I change the character set to 238 I am able to type the corresponding characters. Please give some more detailed informatio of your problem.

 

Regards,

Koen

Nov 16, 2009 at 7:40 AM

 

Hi Koen,
My application is a multilanguage application. The language I have so far are English and Romanian (character set 0 and 238 respectively). When I use English everything is ok. When I switch to romanian and the Language for non-unicode application (in Control Panel -> Regional and Languages Options) is still set to English the special characters are not displayed properly. I do it using the following code:
WITH .Title
.FontCharSet = 238
.Alignment = 2
.Caption = lcChartTitle
.FontItalic = .F.
.FontName = 'Arial'
.FontSize = 14
.ForeColor = RGB(0,0,0)
ENDWITH
lcChartTitle is the title of the chart stored in the language table. This very value is displayed properly in a label or edit box that has FontCharSet = 238.
I have uploaded to the link bellow a zip file containing two charts exported to png:
MyChart-correct.png - this is with Language for non-unicode applications set to Romanian in Control Panel
Mychart-incorrect.png - this is with Language for non-unicode application set to English
You will notice the diference between the two images by looking at the chart title. I am avoiding this problem for the rest of the controls in the app, by setting the control's FontCharSet property to 238. This seems not to work with charts.
http://www.mediafire.com/?i35jtmmtczd
Thank you very much.
All best,
Lucian
Hi Koen,
My application is a multilanguage application. The language I have so far are English and Romanian (character set 0 and 238 respectively). When I use English everything is ok. When I switch to romanian and the Language for non-unicode application (in Control Panel -> Regional and Languages Options) is still set to English the special characters are not displayed properly. I do it using the following code:
WITH .Title
.FontCharSet = 238
.Alignment = 2
.Caption = lcChartTitle
.FontItalic = .F.
.FontName = 'Arial'
.FontSize = 14
.ForeColor = RGB(0,0,0)
ENDWITH
lcChartTitle is the title of the chart stored in the language table. This very value is displayed properly in a label or edit box that has FontCharSet = 238.
I have uploaded to the link bellow a zip file containing two charts exported to png:
MyChart-correct.png - this is with Language for non-unicode applications set to Romanian in Control Panel
Mychart-incorrect.png - this is with Language for non-unicode application set to English
You will notice the diference between the two images by looking at the chart title. I am avoiding this problem for the rest of the controls in the app, by setting the control's FontCharSet property to 238. This seems not to work with charts.
http://www.mediafire.com/?i35jtmmtczd
Thank you very much.
All best,
Lucian