This project is read-only.

Question from a newbie

Topics: General
Aug 8, 2012 at 9:20 PM


I hope you will forgive my stupid question.  I am new to FoxPro coming from .NET.  I need to work on some legacy applications and I am already getting the hang of it.  I found the Thor add-in and tried running it.  I seem to have successfully run it as two new menus appear on menu bar namely: "Thor" and "Thor Tools".  I also installed the PEM Editor from the update screen but when I access "Manage PEM Editor access" from the "Thor" menu, I get the error "Alias '_OPEMEDITOR' is not found".  When I access the same menu from the "Thor Tools" menu, I get the "LOTHORINFO is not an object" error.

I've tried deleting and re-installing but to no avail.

I don't know what I am doing wrong as I am new to FoxPro so I hope you can help me out.  Please try to spell out clearly what I might have missed as I might not be able to understand some FoxPro specific jargons.

By the way, I am using Visual FoxPro 9.0 SP2.




Aug 10, 2012 at 2:59 PM

Eric - Let's examine a few other things.

First, please test if PEM Editor will launch properly.  Go to Applications -> Thor Tools -> Apps -> PEM Editor -> Run or Show PEM Editor.

Tell us if the PEM Editor UI form appears.

Aug 10, 2012 at 4:23 PM

Hi Matt,

Thanks for the reply.  I don't have the "Run or Show PEM Editor" menu.  What I have is Thor Tools -> Applications -> PEM Editor -> Manage PEM Editor access.  Clicking that menu gives me the message "LOTHORINFO is not an object".  If I click on Thor -> Modify Tools -> Applications -> PEM Editor -> Manage PEM Editor access, I get the message "Alias '_OPEMEDITOR' is not found".  When I go to Thor -> Configure (Options Tab), some items on the listbox gives me a message "Object _OPEMEDITOR is not found".

When I go to Thor -> Check for Updates, everything seems to be installed ok because I don't see any updates that need to be downloaded.  I did get notifications when I first installed Thor about the updates for ThorRepository and PEM Editor which I updated.




Aug 10, 2012 at 6:06 PM
Edited Aug 10, 2012 at 6:08 PM

OK, I have been able to reproduce this situation on my machine, and I have talked with Jim Nelson, the Thor & PEM Editor developer. He is travelling this week and cannot reply here like he normally would, but I have chatted with him about this. He knows exactly what the issue is, and has exaplined it to me. A fix is coming very soon (2-3 days).

However, we can still get you working even before then, I think... So, let's try something.

The errors that you are getting at this point, are actually caused by another error from the oringal installation of PEM Editor.  When you ran the first time, you got a Check for Updates screen where both PEM Editor and the Thor Tool Repository were checked. You then click on Install Updates, and off it goes. However, there is a recently introduced bug that causes an error where you probably saw an error message like this:

Property CLASSDEFINITIONS is not found. 

And you have the options of  Cancel, Suspend, Ignore, Help.

Does this sound right?

Well, if I follow your steps and click Cancel at this message, I get the subsquent errors you are reporting.

However, if you will click "Ignore", the process will continue, and you will still have a good installation of all the tools.

So, the best thing you can do at this point is delete all the Thor stuff from your folders, then unzip the download again, and re-run, but this time, be sure to click on Ignore when you get that initial error.

So, again here are the steps to start over..  Shut down FoxPro, then, using Windows Explorer, delete ALL Thor stuff from whereever you unzipped it to. Now, unzip the files again into a folder, start VFP, then run, click Ignore on the "Property CLASSDEFINITIONS is not found" error.

Then, you should see all the PEME stuff appear in Thor Tools ->Applications -> PEM Editor.

Let me know how this works.


Aug 10, 2012 at 7:40 PM

Hi Matt,

Thanks a lot for the help!  Yes I did encounter that message during the installation.

I did everything you said but I encountered a lot of other messages aside from the one you mentioned and I clicked "Ignore" happily on each on them.  Now, it seems to be working fine and I don't get any other error messages anymore.

Looking forward to the update you mentioned though.

Again, thank you very much again and I appreciate you help a lot.




Aug 10, 2012 at 10:43 PM

By the way, welcome to the FoxPro community!!

Since you are new to FoxPro, you might learn a few things from the PEM Editor videos series that I did, as well the video from my GoFish Code Search tool. You can links to the videos on the pages for those tools here on VFPX.

The videos are based on older versions of these tools, but I bet you'll still learn a few thing if you have time to watch them.

Aug 10, 2012 at 11:08 PM

Hi Matt,

Thanks for the heads-up on the videos.  I'll sure look into them.  What actually brought me to the VFPx page was when I was searching for tools for Refactoring and also something to "Beautify" the code.

I bet those videos will show me more hidden treasures that the PEM Editor and GoFish has.

Again thank you for your help and for the warm welcome.




Aug 11, 2012 at 1:46 AM

You are on on the right track. The last release of VFP was in 2004, so the IDE is a little outdated compared to Visual Studio. But, Jim Nelson has brought many of the Visual Studio features to VFP through Thor Tool Manager, Thor Tool Repository, and PEM Editor. 

Especially these:

  • Extract to Method
  • Extract to Variable
  • Go to Method
  • Go to Definition
  • Close Control Structure
  • High matching parenthesis
  • and so on

(More videos are planned to show off these tools.)

By the way, what brings you from .Net to VFP?

What database are you using in your VFP work? (Native FoxPro DBF's or SQL Server?)

Are you doing client apps or web work with FoxPro?

Aug 11, 2012 at 4:22 AM

Hi Matt,

I needed to support a legacy system done in VFP.  The system was created way back in the later 90's(?) with new functionalities added as needed.  It's a windows application using the native FoxPro's DBF database.  I'm planning to write the codes for the revisions and new functionalities to be more modularized rather than linear.  Since I mostly coded in VB.NET, I am already getting the hang of coding in FoxPro but like you mentioned in your post, I kinda tend to look for features of Visual Studio thus, leading me to this awesome VFPx project.

Would love to see the future videos you'll make.