This project is read-only.

apiShellExecute RUN BUT LOST ACTIVE FORM

Sep 14, 2008 at 9:38 AM
I call apiShellExecute from modalform intoplavelform (wich I call from ctl32 explorerbar topform form).
I get the focus on the other EXE but when I come back to vfp the exe minimized to windows task bar.
Help Please
Sep 16, 2008 at 4:47 PM
Hi Chaim!
Could you send me a sample to reproduce this error?

Emerson
Sep 16, 2008 at 5:33 PM
Hi
Thanks for your respond.
It's huge code.
You can try:
set explorerebar form as top form.
call childform (from explorerbar by 'do form to cvariable') - the child form set as 'in top form' and 'model'.
Now, try run 'notpade' by apiShellExecute, you cant move back and forth in vfp childform and in 'notpad', you can go to notpad but when you try touch vfp the notpad minimized.
I want that the other EXE will be part of the form as you can move in two grids in form back and forth.

Thanks
Sep 16, 2008 at 9:00 PM
Chaim,
Are you sure this is an issue with ExplorerBar control?
This is happening at design time or at runtime?
I've made some tests and even with a form without any ThemedControl, at design time, I have the same results that you.
At runtime, I can't reproduce this behavior.

Sep 17, 2008 at 7:53 AM
I checked again.
You are right.
I have the problem also without the Explorer bar.
Probably its windos/vfp problem.
Any solution?
Thanks
Sep 17, 2008 at 8:18 PM
I really don't now.
Maybe you could post this question in some VFP forums like Universal Thread or Foxite.

PS: Have you solved the DataEnvironment lost problem that you've posted in another thread?