This project is read-only.

Install of Thor/Pem Production Problem

Topics: Bug Information
Sep 10, 2011 at 8:52 PM
Edited Sep 10, 2011 at 9:06 PM

I download and installed productions version of Thor and Pem editor.  Thor was pointing to the 7 beta version, and Pem Editor kept giving me an error "Pem Editor Registration failed. Problem accessing _FoxCode" which was defined as "c:\users\ken\appdata\roaming\microsoft\visual foxpro 9\foxcode.dbf"

I deleted thor and pemeditor folders and files from my directory c:\vfpx.

Now when I run:

clear all

  do c:\vfpx\

do c:\vfpx\pemeditor\

Thor shows up in my system menu but only has Edit,Help,Framework menu items and Pem Editor does now show up at all.  I continue to have error from PemEditor about _foxcode when try to install.  I don't show any pem editor tools in the c:\vfpx\thor\tools folder just 10 ThorInternal files.


 Running Windows 7 machine

Sep 11, 2011 at 1:49 AM

Ken --

I am very sorry about these problems.

The Thor documentation does not make clear what you are to do when re-installing.  All you need do is unzip in the same folder as before, replacing the APP. (I have already corrected this omission in the documentation.)

Since the tables and tools which Thor uses are stored in a sub-folder, removing them first (or installing Thor in a separate place) has the same effect as starting fresh with Thor, as if you were first installing it. 


The problem with the installation of PEM Editor is different, possibly related to using Windows 7 (I don't know).  The actual error message is mis-leading, as it does not specify what the problem was.

Can you see if it was able to create a folder c:\vfpx\pemeditor\FoxCode Backup and that it made a copy of your Foxcode file there?  And, if not, can you create the folder and try installing it again?



Sep 11, 2011 at 10:17 PM
Edited Sep 11, 2011 at 10:18 PM

Hi Jim

The "FoxCode Backup" was not created, I created and tried again with the same error.

As to Thor I removed everything because it was still using the beta 7 pemeditor paths.  I wanted to use the production version, I didn't see anyway short of editing all the prg files to change the path to new version. So I just deleted all the old versions and reinstalled everything.

Sep 11, 2011 at 10:32 PM

Ken --

I am not at all certain where this has left you.  It sounds like PEM Editor is still giving an error message on installation, which would explain why Thor was not referring to the new path for PEM Editor.

Am I to understand that you changed all the paths in the PEM Editor tools already?  I am not sure exactly where you stand now, nor how else I can help.

BTW, you can always contact me directly using my email   JimRNelson@GMail.Com

Sorry again about the problems.

Sep 11, 2011 at 10:51 PM


I deleted the working copy of  foxcode files and copied from the program files.  Everything is working correctly now.

Thanks for your help.



Sep 11, 2011 at 11:04 PM

Ken --

OK, good, glad to hear that.