GDIPlusX - rename system.app?

Topics: Attention VFPX Admins
Feb 7, 2008 at 10:04 AM
Hi

Is there any reason why I can't rename system.app to something else, like gdi_system.app? (Just to avoid possible conflict with another app file of the same name).

Cheers

Brian Abbott
Developer
Feb 7, 2008 at 5:28 PM
Edited Feb 7, 2008 at 5:38 PM
Hi Brian,

You can rename it to anything you want. We designed it to be flexible. You can even pass in a global object to use if you don't want to use _SCREEN. (More info to follow in the long awaited documentation).

Keep in mind that we will probably be adding additional functionality (read namespaces) later that are not necesarily part of GDI+ or System.Drawing. For instance, we already include part of the System.IO namespace. So you may want to use a more generic name, if you want to take advantage of any of the new namespaces in the future and avoid confusion.

Bo Durban
Feb 8, 2008 at 9:50 AM

binarybo wrote:
Hi Brian,

You can rename it to anything you want. We designed it to be flexible. You can even pass in a global object to use if you don't want to use _SCREEN. (More info to follow in the long awaited documentation).

Keep in mind that we will probably be adding additional functionality (read namespaces) later that are not necesarily part of GDI+ or System.Drawing. For instance, we already include part of the System.IO namespace. So you may want to use a more generic name, if you want to take advantage of any of the new namespaces in the future and avoid confusion.

Bo Durban


Thanks Bo, that's useful info. Look forward to the new stuff when it arrives!

On a related note, is it at all likely that the ability to read EXIF data in graphics files will be included at some point?

Brian Abbott
Coordinator
Feb 8, 2008 at 9:45 PM

Thanks Bo, that's useful info. Look forward to the new stuff when it arrives!

On a related note, is it at all likely that the ability to read EXIF data in graphics files will be included at some point?

Brian Abbott


Hi Brian,

Give the following a try...

LOCAL loImage, loPropertyItems, loItem, lvValue, lnCounter
DO (LOCFILE("System.app","APP","Select"))
m.loImage = _screen.system.Drawing.Image.FromFile(GETPIC())
m.loPropertyItems = m.loImage.PropertyItems
FOR EACH m.loItem IN m.loPropertyItems
	m.lvValue = m.loItem.GetValue()
	IF TYPE("m.lvValue") != "A"
		?m.lvValue
	ELSE
		FOR m.lnCounter = 1 TO ALEN(m.lvValue)
			?m.lvValue(m.lnCounter)
		ENDFOR
	ENDIF
ENDFOR
Feb 9, 2008 at 12:16 PM

craigsboyd wrote:



Wow that's good! I'm getting more and more into this.

One small correction to your code (for benefit of lurkers):

IF TYPE("m.lvValue", 1) != "A"

Cheers

Brian Abbott