Code Refs glitches

Topics: Bug Information
May 4, 2010 at 4:45 PM

HI Jim,

First, thanks for your efforts here and with the PEM editor project.

I grabbed this yesterday and went to have a play today. I did a full recompile and rebuild of the APP from the supplied source. Here are some minor issues I've noted.

The install prg change to the registry doesn't seem to be sticking; at least on my system. After I run it, I do see the appropriate value for _FOXREF but it does not survive a VFP restart. It's probably an artifact of my particular setup but I thought I'd mention it.

Clicking the dropdown button next to the folder button near the top left of the form throws this error:

Property CALCULATESHORTCUTMENUPOSITION is not found.

Finally, (and very minor), in the form caption, the "V" in Version appears to be underneath some other object so the \ in the V is obscured. I'd drop in a screenshot here but can't quite figure out if that's allowed.

Thanks again for your efforts on behalf of the whole VFP community.

rk

Coordinator
May 4, 2010 at 8:18 PM

Howdy again --

First of all, I have no idea what is going on with your installation ... The Install is a teensy little program which simply rights to the registry.  Does it still fail if you install it, then close VFP immediately?

I believe that I have corrected the other two issues, in a release that will be out shortly.

 

May 4, 2010 at 8:27 PM

Yep, I looked at the install (and uninstall) and saw what it was doing. Even wrapped it in a little try..catch and stepped through it just to see if it was falling over and it appears to work fine.  I wouldn't give it any further thought, especially since the FoxRef setting is exposed via Tools->Options.

 

 

May 12, 2010 at 8:21 PM
Hi Jim, fyi I figured out why the FOXREF wasn't "sticking" on my system. I'm setting it in code in my startup.prg; so a completely self inflicted wound...
Coordinator
May 12, 2010 at 9:45 PM

Thanks for the update.  Am glad the problem was not on my end.